10% Off All Orders + Free Shipping
Use Coupon Code Joy2017
Hurry! Sale Ends 12/31/17
Avatar

Please consider registering
Guest

Search

— Forum Scope —




— Match —





— Forum Options —





Minimum search word length is 3 characters - maximum search word length is 84 characters

Register Lost password?
sp_Feed sp_TopicIcon
No camera display
sp_NewPost Add Reply sp_NewTopic Add Topic
Avatar
Ijbeaty
Member
Members
Forum Posts: 4
Member Since:
July 17, 2015
sp_UserOfflineSmall Offline
1
July 17, 2015 - 12:30 pm
sp_Permalink sp_Print sp_QuotePost
sp_ReportPost

 I’m sure its either i need to change one option or the video in ports just aren’t working right. I’ll go through everything i’ve tested and how i did so.

 

I have multiple security systems set up and all of the cameras i’m putting into this DVR were working before i used this DVR. I bought it brand new but was unable to use it for a week because i ended up needing a new power supply for my cameras. After getting the new power supply and plugging everything in there was no video feed. I took the power supply to another Camera setup and tested the power supply and it worked so it can’t be that. Then i (just to double check) took one of my cameras that was still in the box and connected it to the DVR with still no video feed. I’m not sure if there is anything outside of just assuming the ports don’t work but if you guys have any ideas please let me know.

Avatar
Dan Maresca
Moderator
Guests

Members

Moderators
Forum Posts: 460
Member Since:
March 27, 2013
sp_UserOfflineSmall Offline
2
July 17, 2015 - 1:01 pm
sp_Permalink sp_Print sp_QuotePost
sp_ReportPost

Good morning,

 

Can you post a link or give me the model number of the DVR? Also please let me know what type of cable, connectors, and length of cable from camera to dvr? Same thing on power supply cable type and how long is the run? Please let me know you if you have the regular display working from dvr, such as having monitor connected to DVR and that you can log into it and see interface.  Does DVR have a hard drive installed and does it show up without errors? Lastly double check you are not connecting the video cable to the audio ports if the DVR has them.

I’m think we are missing a minor detail as to why the video is not working yet. Feel free to chat me or call I’m here all day. 

Avatar
Ijbeaty
Member
Members
Forum Posts: 4
Member Since:
July 17, 2015
sp_UserOfflineSmall Offline
3
July 17, 2015 - 1:58 pm
sp_Permalink sp_Print sp_QuotePost
sp_ReportPost

Sent you a private message.

Avatar
Heath Phillips
Florida
Moderator
Members

Moderators
Forum Posts: 233
Member Since:
January 15, 2014
sp_UserOfflineSmall Offline
4
July 17, 2015 - 2:13 pm
sp_Permalink sp_Print sp_QuotePost
sp_ReportPost

Be sure you do not have an HD-CVI DVR with analog cameras. 

Avatar
Ijbeaty
Member
Members
Forum Posts: 4
Member Since:
July 17, 2015
sp_UserOfflineSmall Offline
5
July 17, 2015 - 2:17 pm
sp_Permalink sp_Print sp_QuotePost
sp_ReportPost

oh crap, yea that might be the issue.

Avatar
Ijbeaty
Member
Members
Forum Posts: 4
Member Since:
July 17, 2015
sp_UserOfflineSmall Offline
Avatar
javajeff
Member
Members
Forum Posts: 132
Member Since:
September 16, 2014
sp_UserOfflineSmall Offline
7
July 20, 2015 - 5:50 pm
sp_Permalink sp_Print sp_QuotePost
sp_ReportPost

Yes.  A Tribrid supports analog cameras.

Avatar
Ted
Moderator
Moderators
Forum Posts: 59
Member Since:
May 15, 2015
sp_UserOfflineSmall Offline
8
November 30, 2015 - 6:15 pm
sp_Permalink sp_Print sp_QuotePost
sp_ReportPost

It’s probably a little late to mention – the camera ljbeaty linked to is a TVI camera, and the DVR is a CVI tribrid.

Forum Timezone: America/New_York

Most Users Ever Online: 127

Currently Online:
20 Guest(s)

Currently Browsing this Page:
1 Guest(s)

Top Posters:

Techpro Security: 404

shockwave199: 179

tubac: 163

Gilberto: 150

MrDeepFreeze: 135

javajeff: 132

Jer7of9: 129

Night Hawk: 98

West Coast Jones: 66

ShawnInFL: 64

Newest Members:

Bobbyloott

WilliamCuh

TimothyHoish

annaxb11

Annarindrype

ThomasSok

BladecliffAdorunund

manuelln16

DentalBib

BoberModAdorunund

Forum Stats:

Groups: 5

Forums: 28

Topics: 1199

Posts: 5272

 

Member Stats:

Guest Posters: 62

Members: 5665

Moderators: 15

Admins: 4

Administrators: Damon Delcoro, Brad Besner, Jose Malave, Gabe Garcia

Moderators: Dan Maresca, Ryan, Zeke Richey, Jorge Nava, Matthew Ernst, LittleBrad, Heath Phillips, Tonya Haley, Dan Millard, Eric Wilson, Brian Lee, Michael, Ted, mwhite, Julius Dilka